Thursday, December 13, 2007

Solaris Faq

What is the command to do an interactive boot from the ok promt?
boot -i

How can i disable STOP+A utility on SUN machines,
which brings system into OK> prompt???.
In /etc/system set abort_enable=0 will disable STOP-A

Where are the templates stored that are copied into the user's home
directories for their personal customizations?
/etc/skel

What SPARC emergency keyboard sequence will take
the system to the ok prompt (forth monitor) but will send output to TTYA?
STOP+A

What file controls system wide password aging?
/etc/shadow

What flag used with patchadd will prevent a later back out by
preventing patchadd from backing up files? If this flag is used,
the patch cannot be removed.
patchadd -d

What file do you put the umask setting in?
The UMASK value for bourne and korn shell users can
be modified system wide by editing the "umask" entry in the
"/etc/profile" file. To change the default UMASK for the C shell,
modify the UMASK variable in "/etc/default/login" file.

Which of the following commands can tell you whether
packets are being delayed or dropped on your network?
spray
% spray -c 100 -d 20 0 -l 2048 pluto
The following example sends 100 packets to a host (-c 100)
with each packet having a size of 2048 bytes (-l 2048). The packets
are sent with a delay time of 20 microseconds between
each burst (-d 20). If you don't use a delay, you may run out of buffers.

Partition sizes can be set manually or from what configuration?
/etc/format.dat

Give the command that will display your default boot device.
eeprom boot-device & not printenv as suggested

How many different kill signals are there?
EXIT HUP INT QUIT ILL TRAP ABRT EMT FPE KILL
BUS SEGV SYS PIPE ALRM TERM USR1 USR2 CLD PWR
WINCH URG POLL STOP TSTP CONT TTIN TTOU VTALRM PROF
XCPU XFSZ WAITING LWP FREEZE THAW CANCEL LOST XRES RTMIN RTMIN+1 RTMIN+2 RTMIN+3 RTMAX-3 RTMAX-2 RTMAX-1 RTMAX


What software install group do you need to select in order to load the compilers?
sunwcprog
End User System Support Software Group (SUNWCuser)
Developer System Support Software Group (SUNWCprog)

What command can you use to display all of your groups?
groups - To display full list
id -a - To diaplsy full list of groups with group id numbers


What does this file /etc/path_to_inst contain and what is the
importance of this file
/etc/path_to_inst contains each device,
its instance name and number along with its physical name.

What is the command can reconfigure devices with out reboot?
devfsadm - solaris 8 onwards

How to restore a corrupted file sytem or trouble shoot bad
super blocks for a FS c0t2d0s5 ?
Well you can also just use the #FSCK -N /dev.dsk/c0t2d0s5
to get the back up block number and then using one of the numbers
that display #FSCK -F ufs -o b=32 can be executed.

How will you add a virtual IP address to a server. Given the interface
qe0 and IP 10.10.1.150
# ifconfig qe0:1 10.10.1.150 up
where "qe0" is an interface (e.g., le0) and N is a number between 1 and
. Removing the pseudo interface and associated address is done
with "ifconfig qe0:1 10.10.1.150 down".
As with physical interfaces, all you need to do is make the
appropriate /etc/hostname.qe0:X file.

Boot phases of Solaris Operating Environment are:
1.boot PROM
2.boot programs like bootblk,ufsboot
3.kernel initialization like loading modules
4. init phase

How do you determin which Run Level the sytem is running
who -r

How would you find out what version of Solaris is currently running?
Run the command showrev. There's a man page on showrev and
there are switches to help you do whatever you're trying to do


As a system administrator, how would you figure out the system
transaction is slow between the system you logged into and from the system you did telnet login?
-time

# Display the parent/child tree of a process ?
- ptree Example: ptree 1267

# Show the working directory of a process ?
- pwdx Example: pwdx 1267

# Display the processes current open files ? -
pfiles Example: pfiles 1267

Alternative for top command ? -
prstat -a